0%

HDU 1890 Robotic Sort | Splay

Robotic Sort

Time Limit: 6000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Somewhere deep in the Czech Technical University buildings, there are laboratories for examining mechanical and electrical properties of various materials. In one of yesterday’s presentations, you have seen how was one of the laboratories changed into a new multimedia lab. But there are still others, serving to their original purposes.

In this task, you are to write software for a robot that handles samples in such a laboratory. Imagine there are material samples lined up on a running belt. The samples have different heights, which may cause troubles to the next processing unit. To eliminate such troubles, we need to sort the samples by their height into the ascending order.

Reordering is done by a mechanical robot arm, which is able to pick up any number of consecutive samples and turn them round, such that their mutual order is reversed. In other words, one robot operation can reverse the order of samples on positions between A and B.

A possible way to sort the samples is to find the position of the smallest one (P1) and reverse the order between positions 1 and P1, which causes the smallest sample to become first. Then we find the second one on position P and reverse the order between 2 and P2. Then the third sample is located etc.

1

The picture shows a simple example of 6 samples. The smallest one is on the 4th position, therefore, the robot arm reverses the first 4 samples. The second smallest sample is the last one, so the next robot operation will reverse the order of five samples on positions 2–6. The third step will be to reverse the samples 3–4, etc.

Your task is to find the correct sequence of reversal operations that will sort the samples using the above algorithm. If there are more samples with the same height, their mutual order must be preserved: the one that was given first in the initial order must be placed before the others in the final order too.

Input

The input consists of several scenarios. Each scenario is described by two lines. The first line contains one integer number N , the number of samples, 1 ≤ N ≤ 100 000. The second line lists exactly N space-separated positive integers, they specify the heights of individual samples and their initial order.

The last scenario is followed by a line containing zero.

Output

For each scenario, output one line with exactly N integers P1 , P1 , . . . PN ,separated by a space. Each Pi must be an integer (1 ≤ Pi ≤ N ) giving the position of the i-th sample just before the i-th reversal operation.

Note that if a sample is already on its correct position Pi , you should output the number Pi anyway, indicating that the “interval between Pi and Pi ” (a single sample) should be reversed.

Sample Input

6
3 4 5 1 6 2
4
3 3 2 1
0

Sample Output

4 6 4 5 6 6
4 2 4 4

题意

机械臂可以翻转整个数列中连续的某一串序列,要求用这种翻转的方式完成整个数列的排序。

分析

排序的方式题目已经给出了,只需要按照要求去模拟即可,而模拟这个过程的方法很重要,时间上还是要求比较严格的。

获取数据之后首先排序一遍,记录下排完序之后每个点原本的位置,这个就是等一下在树中进行操作时需要用到的了。

题目要求的翻转方式是每次刚好将第i个翻转到位,每次翻转之后固定一个数,然后翻转下一个数,直到翻转完全部的数。

只要用splay将每次的目标结点移到根,那么其左子树的大小就是数列中排在它左边的点的个数,也就是题目要求输出的部分。然后翻转整个左子树(将子树的左右儿子交换,递归到底),删除根,就完成了一次操作。

思路很清晰,但是这里遇到的问题是如何翻转左子树,如果每次都手动递归向下翻转所有树的话,时间上必然是要超时的。从线段树中启发,可以用标记的方式标记翻转情况,减少直接操作的次数,用传递标记的方式传下去:

输出结果后,将左子树打上翻转标记,然后删除根。

一个结点翻转标记的传递必须要发生在对其子树进行操作之前,本题中,后续直接操作子树的过程是接下来的删根操作(我的代码中要从左右子树中找前后继)和下一轮将下一个目标移到根的过程。所以要在这两个过程前加入维护的过程。

删根中找前后继因为是从上往下的,刚好可以顺便查看标记情况对子树完成翻转。问题是下一次提升结点到根的时候不能确定上方父节点的标记情况,因此只能从当前结点开始向上查到根,然后从根开始向下回到目标结点,一路查看标记完成翻转维护……这一块我只能想出这个方法了,不知道其他大神有没有什么更好的方法。这里用递归反查结果栈溢出了,只好开了个大数组记录,,,最后提交AC的通过时间也比较长,应该确实是还有更好的方法吧

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
/* ***********************************************
MYID : Chen Fan
LANG : G++
PROG : HDU1890
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef struct nod
{
int key,num;
} node;

#define MAXN 100010

node a[MAXN];
int list[MAXN];

bool op(node a,node b)
{
if (a.key==b.key) return a.num<b.num;
else return a.key<b.key;
}

int sons[MAXN][2];
int father[MAXN],size[MAXN],data[MAXN];
bool flag[MAXN];
int spt=0,spttail=0;

void rotate(int x,int w) //rotate(node,0/1)
{
int y=father[x];
sons[y][1-w]=sons[x][w];
if (sons[x][w]) father[sons[x][w]]=y;

father[x]=father[y];
if (father[y])
if (y==sons[father[y]][0]) sons[father[y]][0]=x;
else sons[father[y]][1]=x;

sons[x][w]=y;
father[y]=x;

size[x]=size[y];
size[y]=size[sons[y][0]]+size[sons[y][1]]+1;
}

void splay(int x,int y) //splay(node,position)
{
if (!x) return ;
//check(x);
while(father[x]!=y)
{
if (father[father[x]]==y)
if (x==sons[father[x]][0]) rotate(x,1);
else rotate(x,0);
else
if (father[x]==sons[father[father[x]]][0])
if (x==sons[father[x]][0])
{
rotate(father[x],1);
rotate(x,1);
} else
{
rotate(x,0);
rotate(x,1);
}
else
if (x==sons[father[x]][1])
{
rotate(father[x],0);
rotate(x,0);
} else
{
rotate(x,1);
rotate(x,0);
}
}
if (!y) spt=x;
}

void insert(int w) //insert(value)
{
spttail++;
data[spttail]=w;
size[spttail]=1;
sons[spttail][0]=0;
sons[spttail][1]=0;
flag[spttail]=0;
if (!spt)
{
father[spttail]=0;
spt=spttail;
} else
{
int x=spt;
while(1)
{
size[x]++;
if (w<data[x])
if (sons[x][0]) x=sons[x][0];
else break;
else
if (sons[x][1]) x=sons[x][1];
else break;
}
father[spttail]=x;
if (w<data[x]) sons[x][0]=spttail;
else sons[x][1]=spttail;
splay(spttail,0);
}
}

void down(int x)
{
flag[x]=0;
int t=sons[x][1];
sons[x][1]=sons[x][0];
sons[x][0]=t;
flag[sons[x][0]]=1-flag[sons[x][0]];
flag[sons[x][1]]=1-flag[sons[x][1]];
}

void del(int x) //del(number)
{
splay(x,0);

int y=sons[x][0];
if (flag[y]) down(y);
while(sons[y][1])
{
y=sons[y][1];
if (flag[y]) down(y);
}

int z=sons[x][1];
if (flag[z]) down(z);
while(sons[z][0])
{
z=sons[z][0];
if (flag[z]) down(z);
}

if (y)
{
splay(y,0);
size[y]--;
if (z)
{
splay(z,y);
sons[z][0]=0;
size[z]--;
} else sons[y][1]=0;
} else
{
if (z)
{
splay(z,0);
sons[z][0]=0;
size[z]--;
} else
{
spt=0;
spttail=0;
}
}
}

void check(int x)
{
//if (father[x]) check(father[x]);
//if (flag[x]) down(x);
int i=0;
while (father[x])
{
i++;
list[i]=x;
x=father[x];
}
while (i>0)
{
if (flag[list[i]]) down(list[i]);
i--;
}
}

int main()
{
//freopen("1.txt","r",stdin);

int n;
scanf("%d",&n);
while(n)
{
spt=0;
spttail=0;
for (int i=1;i<=n;i++)
{
scanf("%d",&a[i].key);
a[i].num=i;
insert(i);
}
sort(&a[1],&a[n+1],op);

for (int i=1;i<=n;i++)
{
check(a[i].num);
splay(a[i].num,0);
if (i>1) printf(" ");
printf("%d",size[sons[spt][0]]+i);

flag[sons[spt][0]]=1-flag[sons[spt][0]];

del(spt);
}

printf("\n");
scanf("%d",&n);
}

return 0;
}