0%

HDU 1068 Girls and Boys 二分图最大独立集(最大二分匹配)

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 …
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2

题意

题目给定一些男女生之间相互的romantic关系,要求找出一个最大的集合,使得该集合中的所有男女生之间都不存在romantic关系。

分析

一个二分图的最大独立集点数与最大二分匹配个数有直接的关系:

最大独立集点数 = 顶点数 - 最大二分匹配对数

故本题直接转化为求最大二分匹配即可,需要注意的是,题中给出的条件是1指向2,2也会指向1,所以最终算出来的匹配数其实是实际对数的两倍,最终被顶点数减去之前首先需要折半。

基础二分匹配练手题。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
/*
ID: Chen Fan
PROG: hdu1068
LANG: G++
*/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

typedef struct nod
{

int a,b;
} node;
node a[1000];
int result[1000],start[1000],num[1000];
bool flag[1000];

bool op(node a,node b)
{
if (a.a==b.a) return a.b<b.b;
else return a.a<b.a;
}

bool find(int s)
{
for (int i=0;i<num[s];i++)
{
int now=a[start[s]+i].b;
if (!flag[now])
{
flag[now]=true;
if (result[now]==-1||find(result[now]))
{
result[now]=s;
return true;
}
}
}
return false;
}

int main()
{
int n;
while (scanf("%d",&n)!=EOF)
{
int tail=0;
for (int i=1;i<=n;i++)
{
int x,p;
scanf("%d: (%d",&x,&p);
getchar();
for (int j=1;j<=p;j++)
{
int y;
scanf("%d",&y);
tail++;
a[tail].a=x;
a[tail].b=y;
}
}
sort(&a[1],&a[tail+1],op);
int o=-1;
memset(num,0,sizeof(num));
for (int i=1;i<=tail;i++)
{
if (o!=a[i].a)
{
o=a[i].a;
start[o]=i;
}
num[o]++;
}

memset(result,-1,sizeof(result));
int ans=0;
for (int i=0;i<n;i++)
{
memset(flag,0,sizeof(flag));
if (find(i)) ans++;
}

printf("%d\n",n-ans/2);
}

return 0;
}